Problem here
Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? *Problem** Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p q <= 26. This represents a p q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. If no such path exist, you should output impossible on a single line.
Sample Input
31 12 34 3
Sample Output
Scenario #1:A
1Scenario #2:impossible
Scenario #3:A1B3C1A2B4C2A3B1C3A4B2C4
1Scenario #2:impossible
Scenario #3:A1B3C1A2B4C2A3B1C3A4B2C4
Source
TUD Programming Contest 2005, Darmstadt, Germany
Solution
#include <iostream>
#include <memory.h>
using namespace std;
int dx[8] = {-2, -2, -1, -1, 1, 1, 2, 2};
int dy[8] = {-1, 1, -2, 2, -2, 2, -1, 1};
int allStep;
char ans[100];
bool visit[100][100];
bool ok;
int p, q;
void dfs(int cnt, int x, int y){
if(cnt == allStep){
for(int i = 0; i < 2*cnt; i++){
cout << ans[i];
}
cout << endl;
ok = true;
return ;
}
for(int i = 0; i < 8; i++){
if(ok == false){
int new_x = x+dx[i];
int new_y = y+dy[i];
if(new_x > 0 && new_y > 0 && new_x <= q && new_y <= p){
if(visit[new_x][new_y] == false){
visit[new_x][new_y] = true;
ans[2*cnt] = 'A' + new_x-1;
ans[2*cnt+1] = '1' + new_y-1;
dfs(cnt+1, new_x, new_y);
visit[new_x][new_y] = false;
}
}
}
}
}
int main(){
int kase;
cin >> kase;
for(int ks = 1; ks <= kase; ks++){
cin >> p >> q;
allStep = p*q;
memset(visit, false, sizeof(visit));
ok = false;
visit[1][1] = true;
ans[0] = 'A';
ans[1] = '1';
cout << "Scenario #" << ks << ":" << endl;
dfs(1, 1, 1);
if(ok == false){
cout << "impossible" << endl;
}
cout << endl;
}
return 0;
}
No comments:
Post a Comment