Sunday, February 28, 2016

【UVa】11292 - Dragon of Loowater

Problem here

Problem

Once upon a time, in the Kingdom of Loowater, a minor nuisance turned into a major problem. The shores of Rellau Creek in central Loowater had always been a prime breeding ground for geese. Due to the lack of predators, the geese population was out of control. The people of Loowater mostly kept clear of the geese. Occasionally, a goose would attack one of the people, and perhaps bite off a finger or two, but in general, the people tolerated the geese as a minor nuisance.One day, a freak mutation occurred, and one of the geese spawned a multi-headed fire-breathing dragon. When the dragon grew up, he threatened to burn the Kingdom of Loowater to a crisp. Loowater had a major problem. The king was alarmed, and called on his knights to slay the dragon and save the kingdom. The knights explained: “To slay the dragon, we must chop off all its heads. Each knight can chop off one of the dragon’s heads. The heads of the dragon are of different sizes. In order to chop off a head, a knight must be at least as tall as the diameter of the head. The knights’ union demands that for chopping off a head, a knight must be paid a wage equal to one gold coin for each centimetre of the knight’s height.” Would there be enough knights to defeat the dragon? The king called on his advisors to help him decide how many and which knights to hire. After having lost a lot of money building Mir Park, the king wanted to minimize the expense of slaying the dragon. As one of the advisors, your job was to help the king. You took it very seriously: if you failed, you and the whole kingdom would be burnt to a crisp!

Input 

The input contains several test cases. The first line of each test case contains two integers between 1 and 20000 inclusive, indicating the number n of heads that the dragon has, and the number m of knights in the kingdom. The next n lines each contain an integer, and give the diameters of the dragon’s heads, in centimetres. The following m lines each contain an integer, and specify the heights of the knights of Loowater, also in centimetres. The last test case is followed by a line containing ‘0 0’.

Output

For each test case, output a line containing the minimum number of gold coins that the king needs to pay to slay the dragon. If it is not possible for the knights of Loowater to slay the dragon, output the line ‘Loowater is doomed!’.

Sample Input

2 3 
2 1 
10 
0 0

Sample Output

11
Loowater is doomed!

Solution

greedy
#include <iostream> #include <algorithm> #include <vector> using namespace std; int main(){ int n, m; while(cin >> n >> m){ if(n == 0 && m == 0) break; vector<int> d, k; int tmp; for(int i = 0; i < n; i++){ cin >> tmp; d.push_back(tmp); } for(int i = 0; i < m; i++){ cin >> tmp; k.push_back(tmp); } sort(d.begin(), d.end()); sort(k.begin(), k.end()); int sum = 0; for(int i = 0; i < k.size(); i++){ for(int j = 0; j < d.size(); j++){ if(k[i] >= d[j]){ sum += k[i]; d.erase(d.begin()+j); break; } } } if(d.size() > 0) cout << "Loowater is doomed!" << endl; else cout << sum << endl; } return 0; }

Friday, February 26, 2016

【UVa】11057 – Exact Sum

Problem here

Problem

Peter received money from his parents this week and wants to spend it all buying books. But he does not read a book so fast, because he likes to enjoy every single word while he is reading. In this way, it takes him a week to finish a book. As Peter receives money every two weeks, he decided to buy two books, then he can read them until receive more money. As he wishes to spend all the money, he should choose two books whose prices summed up are equal to the money that he has. It is a little bit difficult to find these books, so Peter asks your help to find them.

Input

Each test case starts with 2 ≤ N ≤ 10000, the number of available books. Next line will have N integers, representing the price of each book, a book costs less than 1000001. Then there is another line with an integer M, representing how much money Peter has. There is a blank line after each test case. The input is terminated by end of file (EOF).

Output

For each test case you must print the message: 『Peter should buy books whose prices are i and j.』, where i and j are the prices of the books whose sum is equal do M and i ≤ j. You can consider that is always possible to find a solution, if there are multiple solutions print the solution that minimizes the difference between the prices i and j. After each test case you must print a blank line.

Input Sample

2
40 40
80
5
10 2 6 8 4
10

Output Sample

Peter should buy books whose prices are 40 and 40.
Peter should buy books whose prices are 4 and 6.

Solution

取得兩數的和是本錢的差值
然後在差值中找最小
注意輸出後要再空一行
#include <iostream>
#include <vector>
#include <algorithm>
#include <stdio.h>
using namespace std;
vector<int>books;
int book;
int money;
int ansI, ansJ;
void slove(int l, int r){
    int dis = 9999999;
    for(int i = 0; i < books.size(); i++){
        for(int j = 0; j < books.size(); j++){
            if(books[i] + books[j] == money && books[i] != money && books[j] != money){
                int tmp = (books[i] < books[j]) ? (books[j] - books[i]) : (books[i] - books[j]);
                if(tmp < dis){
                    dis = tmp;
                    ansI = i;
                    ansJ = j;
                }
            }
        }
    }
}
 
int main(){
     
    int n;
    while(cin >> n){
        for(int i = 0; i < n; i++){
            cin >> book;
            books.push_back(book);
        }
        cin >> money;
        sort(books.begin(), books.end());
        slove(0, books.size()-1);
        cout << "Peter should buy books whose prices are " << books[ansI] << " and "<< books[ansJ] << "." << endl;
        cout << endl;
        char c = getchar();
        books.clear();
        ansI = 0;
        ansJ = 0;
    }
     
    return 0;
}