Problem here
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.'.' - a black tile '#' - a red tile '@' - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
Sample Output
45
45
Source
Solution
#include <iostream>
#include <memory.h>
using namespace std;
int w, h;
int map[100][100];
int cnt;
void dfs(int x, int y){
if(x < 0 || y < 0 || x >= h || y >= w || map[x][y] == 1)
return;
cnt++;
map[x][y] = 1;
dfs(x+1, y);
dfs(x, y+1);
dfs(x-1, y);
dfs(x, y-1);
}
int main(){
while(cin >> w >> h){
if(w == 0 && h == 0)
break;
int p, q;
cnt = 0;
memset(map, 0, sizeof(map));
for(int i = 0; i < h; i++){
for(int j = 0; j < w; j++){
char input;
cin >> input;
if(input == '@'){
p = i;
q = j;
}
if(input == '#')
map[i][j] = 1;
}
}
dfs(p, q);
cout << cnt << endl;
}
return 0;
}
No comments:
Post a Comment