Saturday, August 20, 2016

【POJ】Y2K Accounting Bug

Problem here

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.
Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237 
375 743 
200000 849694 
2500000 8000000 
Sample Output
116 
28 
300612 
Deficit

Solution

#include <iostream>
using namespace std;
/*
ssssd-> ssssd ssssd ss
sssdd-> sssdd sssdd ss
ssddd-> ssddd ssddd ss
sdddd-> sdddd sdddd sd
ddddd-> ddddd ddddd dd
*/
int main(){
    int s, d;
    while(cin >> s >> d){
        int ans = 0;
        if(4*s < d)
            ans = 10*s - 2*d;
        else if(3*s < 2*d)
            ans = 8*s - 4*d;
        else if(2*s < 3*d)
            ans = 6*s - 6*d;
        else if(s < 4*d)
            ans = 3*s - 9*d;
        else
            ans = -12*d;

        if(ans > 0)
            cout << ans << endl;
        else
            cout << "Deficit" << endl;
    }

    return 0;
}

No comments:

Post a Comment