Friday, January 8, 2016

【UVa】612 – DNA Sorting

題目內容

One measure of unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequenceDAABEC“, this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence <tt>AACEDGG</tt>'' has only one inversion (<tt>E</tt> and <tt>D</tt>)--it is nearly sorted--while the sequenceZWQM" has 6 inversions (it is as unsorted as can be–exactly the reverse of sorted).
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters ACG, and T). However, you want to catalog them, not in alphabetical order, but rather in order of sortedness'', frommost sorted" to “least sorted". All the strings are of the same length.

Input 

The first line of the input is an integer M, then a blank line followed by M datasets. There is a blank line between datasets.
The first line of each dataset contains two integers: a positive integer n ( $0 < n \le 50$) giving the length of the strings; and a positive integer m ( $0 < m \le 100$) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output 

For each dataset, output the list of input strings, arranged from most sorted'' toleast sorted". If two or more strings are equally sorted, list them in the same order they are in the input file.
Print a blank line between consecutive test cases.

Sample Input 

1

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output 

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

Solution

其實就是套用ASCII後從字串中的i開始向右數有多少個比i大的數,最後就是排序


#include <iostream>
#include <vector>
#include <string>
#include <cctype>
#include <algorithm>
#include <stdio.h>
#include <stdlib.h>
 
using namespace std;
 
struct dna{
    string str_data;
    int sort;
    int id;
     
};
 
int checkSort(string str){
    int count = 0;
    for(int i = 0; i < str.length(); i++){
        for(int j = i; j < str.length(); j++){ if(str[i] > str[j]){
                count++;
            }
        }
    }
    return count;
}
 
bool cmp(dna &a, dna &b){
    if(a.sort == b.sort)
        return a.id < b.id;
    return a.sort < b.sort; } int main(){ int M; string p; while(cin >> M){
        while(M--){
            getline(cin, p);           
            int n, m;
            cin >> n >> m;
            vector<dna> dnas;
            dna da;
            string datas;
            for(int i = 0; i < m; i++){ da.id = i; cin >> datas;
                da.str_data = datas;
                 
                da.sort = checkSort(da.str_data);
                dnas.push_back(da);
            }
            sort(dnas.begin(), dnas.end(), cmp);
            for(int i = 0; i <= dnas.size()-1; i++){
                cout << dnas[i].str_data << endl; } if(M > 0){
                cout << endl;
            }
             
        }
    }
     
    return 0;
}

No comments:

Post a Comment