Monday, December 28, 2015

【UVa】1585 – Score

題目內容

Time limit: 3.000 seconds
There is an objective test result such as “OOXXOXXOOO“. An <tt>O</tt>' means a correct answer of a problem and anX‘ means a wrong answer. The score of each problem of this test is calculated by itself and its just previous consecutive <tt>O</tt>'s only when the answer is correct. For example, the score of the 10th problem is 3 that is obtained by itself and its two previous consecutiveO‘s.
Therefore, the score of <tt>OOXXOXXOOO</tt>" is 10 which is calculated by1+2+0+0+1+0+0+1+2+3″.
You are to write a program calculating the scores of test results.

Input 

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing a string composed by <tt>O</tt>' andX‘ and the length of the string is more than 0 and less than 80. There is no spaces between <tt>O</tt>' andX‘.

Output 

Your program is to write to standard output. Print exactly one line for each test case. The line is to contain the score of the test case.
The following shows sample input and output for five test cases.

Sample Input 

5 
OOXXOXXOOO 
OOXXOOXXOO 
OXOXOXOXOXOXOX 
OOOOOOOOOO 
OOOOXOOOOXOOOOX

Sample Output 

10 
9 
7 
55 
30

Solution

將O的出現次數加上,遇到X時就將出現次數清零就可以了


#include <iostream>
#include <string>
#include <stdio.h>
using namespace std;
 
int main(){
    int t;
    while(cin >> t){
        while(t--){
            string input;
            cin >> input;
            int countChara = 0; //O的出現次數
            int result = 0;
            for(int i = 0; i < input.length(); i++){
                     
                if(input[i] == 'O'){
                    countChara++;
                    result += countChara;
                }else if(input[i] == 'X'){
                    countChara = 0;
                }
            }
            cout << result << endl;
             
        }
    }
     
}

No comments:

Post a Comment